• Theme Requirements

  • The optimal hosting settings for Nexus themes are:

    - Theme version: latest version
    - WordPress version: most recent stable version
    - WordPress memory limit: > 64MB (on our hosting service its set to 512MB)
    - Server memory limit: > 64 MB
    - PHP version: PHP 7.1 or higher
    - PHP Max Input Vars; at least 1000
    - Post_max_size: > 1 MB (on our hosting service its set to 16MB)
    - Max upload size: > 1 MB

    The theme will work on any hosting provider that supports wordpress.org hosting:
    - NexusThemes
    - GoDaddy
    - Bluehost
    - etc.

    From past experience we know the following hosting providers conflict with our themes;
    - Flywheel
    - WordPress.com

    ‚ÄčThere are no operating system specific requirements (it will run on any platform that is capable of running wordpress from the wordpress.org website, the only requirements are you can install WordPress on your hosting).

    PHP version 5.6 or higher. Also ensure you have the following PHP extensions enabled; iconv

    WP 4.8 or higher.

  • The following questions concern functions exclusively available for clients having chosen to host their website with Nexus.